Cisco ASA 5520 + NAT + outside, нужна помощь

[ Версия для печати ]
Добавить в Facebook Добавить в Twitter Добавить в Вконтакте Добавить в Одноклассники
  [ ОТВЕТИТЬ ] [ НОВАЯ ТЕМА ]
AlexDLM
26.04.2013 - 21:50
Статус: Offline


Как же это ох..о накатить с утра водчары

Регистрация: 3.04.10
Сообщений: 1982
6
Есть мнение, что среди уважаемых форумчан есть знатоки. Если нет- значит не судьба.

Есть задачка:
Схема: ISP->ASA5520->Cisco 3745->клиент. C ASA никогда не работал. По блогам и руководствам на различных ресурсах настроил удачно, на стенде начальная конфигурация завелась. При переносе в рабочую сеть и допиливании конфигурации под дополнительные требования перестали видеть ISP. Помогите решить, с меня магарыч.
 
[^]
Yap
[x]



Продам слона

Регистрация: 10.12.04
Сообщений: 1488
 
[^]
Sunray
26.04.2013 - 21:58
1
Статус: Offline


Ч Е Л О В Е К

Регистрация: 23.11.09
Сообщений: 6852
где допиливал там и смотреть нужно
 
[^]
СтебкаРазин
26.04.2013 - 22:01
0
Статус: Offline


Ярила

Регистрация: 20.09.12
Сообщений: 2252
Аксес листы добавлял?
 
[^]
AlexDLM
26.04.2013 - 22:03
0
Статус: Offline


Как же это ох..о накатить с утра водчары

Регистрация: 3.04.10
Сообщений: 1982
Цитата (СтебкаРазин @ 27.04.2013 - 00:01)

Аксес листы добавлял?

Имеешь в виду permit ip any any? добавлял. с этой железкой не спасает.

Это сообщение отредактировал AlexDLM - 26.04.2013 - 22:05
 
[^]
СтебкаРазин
26.04.2013 - 22:04
0
Статус: Offline


Ярила

Регистрация: 20.09.12
Сообщений: 2252
Цитата (AlexDLM @ 26.04.2013 - 23:03)
Цитата (СтебкаРазин @ 27.04.2013 - 00:01)
Аксес листы добавлял?

добавлял. с этой железкой не спасает.

Попробуй убрать их.

Добавлено в 22:05
У тебя АСА выполняет какую роль? Просто модема, куда заходит оптика?

Это сообщение отредактировал СтебкаРазин - 26.04.2013 - 22:06
 
[^]
AlexDLM
26.04.2013 - 22:08
0
Статус: Offline


Как же это ох..о накатить с утра водчары

Регистрация: 3.04.10
Сообщений: 1982
нет, она почти бордер.
 
[^]
SoHm
26.04.2013 - 22:09
0
Статус: Offline


Весельчак

Регистрация: 20.05.11
Сообщений: 101
Цитата
перестали видеть ISP


1. Проверка Route Information Base (таблица маршрутизации)
2. Проверить приходят ли анонсы от ISP, не фильтруются ли они access-list'ами.

А вообще, само описание проблемы - просто вопиющее неуважение к тех.специалистам. Я просто оставлю это здесь.
 
[^]
Pastuh73
26.04.2013 - 22:09
2
Статус: Offline


Ярила

Регистрация: 11.12.12
Сообщений: 1273
Как я вам завидую) Нихуа не понял в ваших месседжах,но за мозги ВАШИ мне непонятные зеленка канешна)

Это сообщение отредактировал Pastuh73 - 26.04.2013 - 22:09
 
[^]
SoHm
26.04.2013 - 22:10
1
Статус: Offline


Весельчак

Регистрация: 20.05.11
Сообщений: 101
show running-config в студию.

Это сообщение отредактировал SoHm - 26.04.2013 - 22:11
 
[^]
СтебкаРазин
26.04.2013 - 22:10
0
Статус: Offline


Ярила

Регистрация: 20.09.12
Сообщений: 2252
SoHm

Согласен. Просто человек только начал вливаться. Я сам таким был. Скорее всего проблема в аксес листах.

Добавлено в 22:12
AlexDLM

Повторюсь и дополню. Смотри аксес листы и маршруты, как сказал SoHm


Это сообщение отредактировал СтебкаРазин - 26.04.2013 - 22:11
 
[^]
AlexDLM
26.04.2013 - 22:15
0
Статус: Offline


Как же это ох..о накатить с утра водчары

Регистрация: 3.04.10
Сообщений: 1982
Цитата (SoHm @ 27.04.2013 - 00:09)
Цитата
перестали видеть ISP


1. Проверка Route Information Base (таблица маршрутизации)
2. Проверить приходят ли анонсы от ISP, не фильтруются ли они access-list'ами.

А вообще, само описание проблемы - просто вопиющее неуважение к тех.специалистам. Я просто оставлю это здесь.

Вы мне учебник цитируете? Я не прошу учебника. Остальное на Вашей совести.


Добавлено в 22:18
Цитата (SoHm @ 27.04.2013 - 00:10)
show running-config в студию.

золотые слова:-) сейчас зашифруюсь и сброшу
 
[^]
AlexDLM
26.04.2013 - 22:21
0
Статус: Offline


Как же это ох..о накатить с утра водчары

Регистрация: 3.04.10
Сообщений: 1982
ciscoasa# sh run
: Saved
:
ASA Version 8.2(1)
!
hostname ciscoasa
names
dns-guard
!
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address x.x.x.171 255.255.255.0
!
interface GigabitEthernet0/1
nameif inside1
security-level 100
ip address 192.168.10.21 255.255.255.0
!
interface GigabitEthernet0/2
nameif inside2
security-level 100
ip address 172.30.0.1 255.255.255.0
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
shutdown
no nameif
no security-level
no ip address
management-only
!
boot system disk0:/asa821-k8.bin
ftp mode passive
same-security-traffic permit inter-interface
object-group network 2_GRE
network-object host 172.30.0.2
object-group network 1_GRE
network-object host 192.168.10.21
access-list test extended permit ip any any log
access-list test extended permit icmp any any log
access-list FROM_1 extended permit gre object-group 1_GRE object-group 2_GRE
access-list FROM_1 extended permit ip any any
access-list FROM_1 extended permit icmp any any log
access-list FROM_2 extended permit gre object-group 2_GRE object-group 1_GRE
access-list FROM_2 extended permit ip any any
access-list in_icmp_outside extended permit icmp any any echo log
access-list ICMP extended permit icmp any any
access-list ICMP extended deny ip any any
pager lines 24
logging enable
logging buffered debugging
mtu outside 1500
mtu inside 1500
mtu orsk 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 2 interface
nat (inside) 2 172.30.8.0 255.255.255.0
access-group ICMP in interface outside
route outside 0.0.0.0 0.0.0.0 85.192.165.1 1
route inside1 192.168.11.0 255.255.255.0 192.168.10.20 1
route inside1 192.168.12.0 255.255.255.0 192.168.10.20 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username otkuser password eevOh2fYOebLFXeP encrypted
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns migrated_dns_map_1
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:43744a99b6d83140c057810a03797916
: end
ciscoasa
 
[^]
SoHm
26.04.2013 - 22:59
2
Статус: Offline


Весельчак

Регистрация: 20.05.11
Сообщений: 101
Полно правил и ничего нигде не применено, поэтому поведение по-умолчанию - drор.

Надо завести zone-pairs, повесить на них правила и интерфейсы. На будущее желательно почитать про Zone-Based Firewall.
Код
!Определяем зоны
zone security inside
zone security outside

!Делаем однонаправленную пару зон
zone-pair security in-to-out source inside destination outside
!Вешаем policy-map для заданного направления
service-policy type inspect Тут_Policy_map_in-out

!Делаем однонаправленную пару зон
zone-pair security in-to-out source outside destination inside
!Вешаем policy-map для заданного направления
service-policy type inspect Тут_Policy_map_out-in

interface range GigabitEthernet0/1 - 2
zone-member security inside

interface GigabitEthernet0/0
zone-member security outside
 
[^]
AlexDLM
27.04.2013 - 10:31
0
Статус: Offline


Как же это ох..о накатить с утра водчары

Регистрация: 3.04.10
Сообщений: 1982
Цитата (SoHm @ 27.04.2013 - 00:59)
Полно правил и ничего нигде не применено, поэтому поведение по-умолчанию - drор.

Аксесс-листы создавались во время теста, когда gre не работал или что-то иное. Если я их убью в конфиге все должно заработать? Сейчас попробую.
 
[^]
SoHm
27.04.2013 - 22:19
0
Статус: Offline


Весельчак

Регистрация: 20.05.11
Сообщений: 101
Цитата (AlexDLM @ 27.04.2013 - 10:31)
Цитата (SoHm @ 27.04.2013 - 00:59)
Полно правил и ничего нигде не применено, поэтому поведение по-умолчанию - drор.

Аксесс-листы создавались во время теста, когда gre не работал или что-то иное. Если я их убью в конфиге все должно заработать? Сейчас попробую.

Access-list'ы вы сами должны настроить согласно своей политике.
Что за схема сети у вас там - я не знаю, что нужен GRE - ipv6, ipsec или что-то иное...

Лучше сначала представить как это всё работает и потом делать.
Удачи!

Это сообщение отредактировал SoHm - 27.04.2013 - 22:34
 
[^]
AlexDLM
28.04.2013 - 04:25
0
Статус: Offline


Как же это ох..о накатить с утра водчары

Регистрация: 3.04.10
Сообщений: 1982
Цитата (SoHm @ 28.04.2013 - 00:19)
Цитата (AlexDLM @ 27.04.2013 - 10:31)
Цитата (SoHm @ 27.04.2013 - 00:59)
Полно правил и ничего нигде не применено, поэтому поведение по-умолчанию - drор.

Аксесс-листы создавались во время теста, когда gre не работал или что-то иное. Если я их убью в конфиге все должно заработать? Сейчас попробую.

Access-list'ы вы сами должны настроить согласно своей политике.
Что за схема сети у вас там - я не знаю, что нужен GRE - ipv6, ipsec или что-то иное...

Лучше сначала представить как это всё работает и потом делать.
Удачи!

Спасибо за помощь, проблема решена. brake.gif
 
[^]
StealtH
29.04.2013 - 17:15
1
Статус: Offline


Йобнутый сисодмин

Регистрация: 28.09.04
Сообщений: 1776
Цитата (AlexDLM @ 28.04.2013 - 04:25)
Спасибо за помощь, проблема решена. brake.gif

Ну так поделись решением, людям, которые, возможно, позже будут иметь аналогичную проблему будет интересно найти в топике ответ, а не гуглить.
 
[^]
AlexDLM
26.05.2013 - 09:25
0
Статус: Offline


Как же это ох..о накатить с утра водчары

Регистрация: 3.04.10
Сообщений: 1982
Извиняюсь за поздний ответ, сам периодически матерю за такое. Решение пиздец как простое, будут вопросы - контакты в профиле
 
[^]
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии. Авторизуйтесь, пожалуйста, или зарегистрируйтесь, если не зарегистрированы.
1 Пользователей читают эту тему (1 Гостей и 0 Скрытых Пользователей) Просмотры темы: 4140
0 Пользователей:
[ ОТВЕТИТЬ ] [ НОВАЯ ТЕМА ]


 
 



Активные темы








Наверх