Разбираюшиеся в Excel

[ Версия для печати ]
Добавить в Facebook Добавить в Twitter Добавить в Вконтакте Добавить в Одноклассники
Страницы: (2) [1] 2   К последнему непрочитанному [ ОТВЕТИТЬ ] [ НОВАЯ ТЕМА ]
crol
28.12.2012 - 19:26
Статус: Offline


Шутник

Регистрация: 29.08.10
Сообщений: 52
Помогите разобраться с не совсем сложной таблицей
Что мы имеем ?
У нас есть таблица с 2 столбцами (записей овер 5000~)
в 1 столбце имеем записи вида
Иванов (хороший)
Сидоров (плохой)
Петров (плохой)
Андреев (хороший)
Что нам нужно ? подсчитать сколько плохих людей у нас есть, для этого я использовал формулу
=СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ("плохой";A1:A4)))
Далее имеем 2 столбец в котором обозначается возраст людей
20
25
30
35
Здесь и проблема, мне нужно отсортировать плохих парней которые моложе 30, т.е. по сути дописать формулу выше..
 
[^]
Yap
[x]



Продам слона

Регистрация: 10.12.04
Сообщений: 1488
 
[^]
1ОлолО1
28.12.2012 - 19:27
Статус: Offline


Шутник

Регистрация: 23.05.12
Сообщений: 42
люди помогите устроится в Газпром pray.gif !!!

Это сообщение отредактировал 1ОлолО1 - 28.12.2012 - 19:27
 
[^]
Skat
28.12.2012 - 19:28
Статус: Offline


Ярила

Регистрация: 10.07.09
Сообщений: 3668
SQL - и будет тебе счастье....
 
[^]
akaFlay
28.12.2012 - 19:28
Статус: Offline


Шутник

Регистрация: 19.08.10
Сообщений: 84
Люди помогите ктонить, я безработный админ =) У кого есть работа? smile.gif
 
[^]
ЗСМ
28.12.2012 - 19:29
Статус: Offline


Ярила

Регистрация: 3.07.12
Сообщений: 4015
Цитата (1ОлолО1 @ 28.12.2012 - 20:27)
люди помогите устроится в Газпром  pray.gif  !!!

Проще тебя в Газпром пристроить, чем по его корявому описанию решить задачку..

Это сообщение отредактировал ЗСМ - 28.12.2012 - 19:29
 
[^]
prorab666
28.12.2012 - 19:30
Статус: Offline


Шутник

Регистрация: 10.10.12
Сообщений: 16
Во время корпаратива лучше заниматься одним делом
 
[^]
ЛимонадныйДжо
28.12.2012 - 19:30
Статус: Offline


Весельчак

Регистрация: 4.03.11
Сообщений: 159
Это из военкомата на ЯП зашли, посоны сваливаем))
 
[^]
4egira
28.12.2012 - 19:33
Статус: Offline


Разбитная разведёнка

Регистрация: 25.03.12
Сообщений: 952
Вот у людей на корпоративе развлекуха - отсортируй петровых/ивановых/сидоровых на хороших-плохих по возрасту... или выпить не дадут biggrin.gif
Принес бы с собой..))

Это сообщение отредактировал 4egira - 28.12.2012 - 19:33
 
[^]
Millioner
28.12.2012 - 19:34
Статус: Offline


Весельчак

Регистрация: 17.03.11
Сообщений: 145
Херня эти формулы!
Есть такая штука Автофильтр.

Для подсчёта хороших людей в условии фильтра ставишь "содержит" "(хороший)", жмакаешь ОК и смотришь строку состояния - там написано кол-во записей.

отсортировать плохих парней которые моложе 30 - читай выше, только хороший меняешь на плохой + в столбике возраста делаешь фильтр по условию "меньше 30"

 
[^]
ШмЭл
28.12.2012 - 19:34
Статус: Offline


Шутник

Регистрация: 29.05.12
Сообщений: 24
Зачем я прочитал это в вечер пятницы... мозг отказался напрочь работать... срочно пива
 
[^]
CTOIIKPaH
28.12.2012 - 19:35
Статус: Offline


>.<

Регистрация: 18.08.09
Сообщений: 1619
Вы РГТУ с красным дипломом не оканчивали? gigi.gif

Это сообщение отредактировал CTOIIKPaH - 28.12.2012 - 19:36
 
[^]
crol
28.12.2012 - 19:38
Статус: Offline


Шутник

Регистрация: 29.08.10
Сообщений: 52
Создал тему обновил а тут овер 10 постов : D по делу 1 и то не подходит, фильтры нельзя

Блин создавал вроде не в инкубаторе, как оно тут оказалось ><

Это сообщение отредактировал crol - 28.12.2012 - 19:39
 
[^]
Dsum
28.12.2012 - 19:41
Статус: Offline


Шутник

Регистрация: 14.11.10
Сообщений: 7
А в чем проблема добавить столбец с ЕСЛИ?
 
[^]
ГарриГорыныч
28.12.2012 - 19:42
Статус: Offline


Настоящий Змей

Регистрация: 12.05.11
Сообщений: 5766
Цитата (1ОлолО1 @ 28.12.2012 - 19:27)
люди помогите устроится в Газпром pray.gif !!!

Во-во gigi.gif
А мне, можете просто денег дать, можно даже прислать, или перевести! lol.gif
 
[^]
some0ne
28.12.2012 - 19:43
Статус: Offline


Восставший из бана

Регистрация: 14.06.11
Сообщений: 166
Цитата (crol @ 28.12.2012 - 20:26)
Здесь и проблема, мне нужно отсортировать плохих парней которые моложе 30, т.е. по сути дописать формулу выше..

Что значит ОТСОРТИРОВАТЬ? Посчитать, отсортировать или отфильтровать???? Ставьте задачу точнее чтоле....


PS Если мы тебе поможем, запостишь сюда телефоны всех плохих девочек моложе 25?

Это сообщение отредактировал some0ne - 28.12.2012 - 19:46
 
[^]
akaFlay
28.12.2012 - 19:48
Статус: Offline


Шутник

Регистрация: 19.08.10
Сообщений: 84
Я паходу всё же не админ т.к. я не могу решить эту задачу или просто хочу пива и не хочу думать, а так прикрепите файл и опишите нормально задачу, так проще будет =) Но когда всё же вы это сделаете я уже буду наверное пьян =)
 
[^]
KopoBko
28.12.2012 - 20:38
Статус: Offline


Молчание - золото

Регистрация: 4.01.12
Сообщений: 67
можно выделить в отдельный столбец единичку если он плохой, посчитать количество этих единичек
 
[^]
ДусяМинометчица
28.12.2012 - 20:54
Статус: Offline


я Дуся, хорошо ебуся. ох...

Регистрация: 12.05.09
Сообщений: 881
а нельзя ли скрин таблицы?
я чет не очень врубилась в содержание столбцов..
 
[^]
Giggles
29.12.2012 - 23:38
Статус: Offline


Шутник

Регистрация: 23.03.12
Сообщений: 88
crol
Я так понял, нужно просто найти количество. Сортировать ничего не нужно. Верно?
Твоя формула:
=СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ("плохой";A1:A4));--(B1:B4<30))
С тебя Джек Дэниэлс:))
 
[^]
Бананский
29.12.2012 - 23:42
Статус: Offline


Ярила

Регистрация: 8.08.12
Сообщений: 1038
Мда-с...))))))))) Я в армии отслужил, но условие - как-то не очень соответствует заданию, а так бы помог)
 
[^]
crol
2.01.2013 - 06:55
Статус: Offline


Шутник

Регистрация: 29.08.10
Сообщений: 52
Спасибо всем помогавшим, формула Giggles'a работает, так же на другом форуме подсказали такую версию

=СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ("плохой";A1:A4))*(B1:B4<=30))

И всё вроде замечательно, но тут оказалось что в ячейке с возрастом иногда бывают записи в виде строчки #Н/Д
И после неё формула перестает работать, есть идеи ?
 
[^]
probneg
2.01.2013 - 10:22
Статус: Offline


Пластилин мира!

Регистрация: 24.03.11
Сообщений: 285
А как формула должна понимать возраст: #Н/Д?
 
[^]
Giggles
2.01.2013 - 13:49
Статус: Offline


Шутник

Регистрация: 23.03.12
Сообщений: 88
Цитата (crol @ 2.01.2013 - 05:55)
Спасибо всем помогавшим, формула Giggles'a работает, так же на другом форуме подсказали такую версию

=СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ("плохой";A1:A4))*(B1:B4<=30))

И всё вроде замечательно, но тут оказалось что в ячейке с возрастом иногда бывают записи в виде строчки #Н/Д
И после неё формула перестает работать, есть идеи ?

Обрабатывать записи с ошибками (такими как "#Н/Д") в конкретном случае неоправданно. Гораздо проще предотвратить их появление. Поэтому, предлагаю видоизменить формулу в ячейках с возрастом, представив ее в виде:
=ЕСЛИОШИБКА(предыдущая формула;0)
Тогда вместо ненавистного "#Н/Д" будет появляться "0".
Если строки, где появлялась "#Н/Д", нам нужно учитывать, то формулу, где мы окончательно вычисляем количество, оставляем без изменений.
Если не нужно учитывать, то видоизменяем:
=СУММПРОИЗВ(--ЕЧИСЛО(НАЙТИ("плохой";A1:A4));--(B1:B4<>0);--(B1:B4<31))
В конце 31, ибо из формулы с другого форума вижу, что 30 должно быть включено.
Если способ с изменением формулы в столбцах, либо добавлением еще одного столбца не катит, то прошу пояснить причины, чтобы разобраться что же все-таки катит.

Добавлено в 13:52
Да, и это, тут в Газпром просятся, возьмите и меня, я вам таблички в экселе рисовать буду:)
 
[^]
probneg
2.01.2013 - 16:47
Статус: Offline


Пластилин мира!

Регистрация: 24.03.11
Сообщений: 285
Цитата (Giggles @ 2.01.2013 - 12:49)
тут в Газпром просятся, возьмите и меня

Это скорее всего для военкомата выборка. Ещё не передумали?
 
[^]
Giggles
2.01.2013 - 16:50
Статус: Offline


Шутник

Регистрация: 23.03.12
Сообщений: 88
Цитата (probneg @ 2.01.2013 - 15:47)
Цитата (Giggles @ 2.01.2013 - 12:49)
тут в Газпром просятся, возьмите и меня

Это скорее всего для военкомата выборка. Ещё не передумали?

Военкомата я не боюсь. В мирное время я Родине более ничего не должен:)
 
[^]
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии. Авторизуйтесь, пожалуйста, или зарегистрируйтесь, если не зарегистрированы.
1 Пользователей читают эту тему (1 Гостей и 0 Скрытых Пользователей) Просмотры темы: 2479
0 Пользователей:
Страницы: (2) [1] 2  [ ОТВЕТИТЬ ] [ НОВАЯ ТЕМА ]


 
 



Активные темы








Наверх